Can't get sound out of CT3670

Discussion about old sound cards, MIDI devices and sound related accessories.

Can't get sound out of CT3670

Postby doaks80 » 2019-1-06 @ 08:55

Can't get adlib or SFX out of an SB32 CT3670 in DOS6.

Followed other threads here and Phils video, none of them work. Not even trying GM.

Installed CTCM and SB16 drivers, they all load at startup fine. Diagnose, aweutil, all seem to recognize and be happy with the card.

But when I play games...nothing comes out. Like it's been muted, but went into the mixer and made sure note muted and all volumes set high.

IRQ is set at 10, as that is the only one CTCM is happy with. If I set it to 7 with CTCU, CTCM changes it to 5. Then in CTCU when I test current settings, it fails to detect IRQ5.

Tried line out and speaker, nothing. Found a game that supports IRQ10...it find the card fine, start fine, but still no sound. Nothing.

Any ideas?

EDIT: I should say I have had many other ISA running OK, including SBPro, crystal, ESS1868.
doaks80
Newbie
 
Posts: 90
Joined: 2018-11-16 @ 21:22

Re: Can't get sound out of CT3670

Postby canthearu » 2019-1-06 @ 09:02

does DIAGNOSE.EXE work?

That normally will work from a clean dos boot to test the card.
canthearu
Member
 
Posts: 320
Joined: 2018-5-26 @ 01:00

Re: Can't get sound out of CT3670

Postby doaks80 » 2019-1-06 @ 09:07

canthearu wrote:does DIAGNOSE.EXE work?

That normally will work from a clean dos boot to test the card.


Everything "works" in as much as they output success. Diagnose outputs the BLASTER settings as normal. The only issue I can detect is the lack of output sound, and the fact I can't really set IRQ to anything other than 10 using CTCU.
doaks80
Newbie
 
Posts: 90
Joined: 2018-11-16 @ 21:22

Re: Can't get sound out of CT3670

Postby canthearu » 2019-1-06 @ 09:36

So diagnose runs, reports success, but NO output to speakers.

If this is the case, there is some fault in the output circuit of the card. Done a good physical inspection of both sides of the cards yet?
canthearu
Member
 
Posts: 320
Joined: 2018-5-26 @ 01:00

Re: Can't get sound out of CT3670

Postby Cbb » 2019-1-06 @ 09:43

you have to set the card to one of “standard” configs
like address 220 or 240, Irq 5 or 7, dMA low 1 or 3, dma high 5 or 7. check other hardware for resources conflicts, may be remove it and check the sound works ok.
then add removed cards one by one checking that sound still works.
if after reinstalling several card sound blaster became speechless, try to reconfigure that card to use another resources.
User avatar
Cbb
Newbie
 
Posts: 28
Joined: 2017-8-09 @ 13:07
Location: Saint Petersburg

Re: Can't get sound out of CT3670

Postby doaks80 » 2019-1-06 @ 10:18

Cbb wrote:you have to set the card to one of “standard” configs
like address 220 or 240, Irq 5 or 7, dMA low 1 or 3, dma high 5 or 7. check other hardware for resources conflicts, may be remove it and check the sound works ok.
then add removed cards one by one checking that sound still works.
if after reinstalling several card sound blaster became speechless, try to reconfigure that card to use another resources.


I tried it in Win95 using normal settings...220/7/1/5...all the drivers seem happy, everything seems OK...just no sound. Maybe the card is stuffed.
doaks80
Newbie
 
Posts: 90
Joined: 2018-11-16 @ 21:22

Re: Can't get sound out of CT3670

Postby The Serpent Rider » 2019-1-06 @ 10:26

The infamous CT3670 strikes again :dead:

Have you tried it under Win 9x or even Win2k/XP? Have you checked threads about reflashing the card into AWE64?
User avatar
The Serpent Rider
Oldbie
 
Posts: 1136
Joined: 2017-3-25 @ 19:07
Location: Stagnant Demesne

Re: Can't get sound out of CT3670

Postby doaks80 » 2019-1-06 @ 10:43

The Serpent Rider wrote:The infamous CT3670 strikes again :dead:

Have you tried it under Win 9x or even Win2k/XP? Have you checked threads about reflashing the card to AWE64?


Yep it sounds like a notorious card. Tried win98 no luck, haven't tried flashing. Don't care if it destroys it, it's going in the bin otherwise.
doaks80
Newbie
 
Posts: 90
Joined: 2018-11-16 @ 21:22


Return to Sound

Who is online

Users browsing this forum: No registered users and 1 guest